Update Will Not Start

My new to me 2016 Ford Expedition had Sync 3 v1.0.15139 installed when I took possession and Android Auto was missing. I upgraded using the Ford method to v3.0.20204 and Android Auto was still missing. I read about downgrading to v2.2.17011 to get Android Auto working and was able to get v2.2.17011 from this site. I put the USB in and the Update started and after several hours, the update was completed and after the unit rebooted, the APIM reported it was on v2.2.17011. Android Auto finally showed up and the unit seems to work without any issues however when I try to update to v3.0.20204 using either the Ford method or using the drive created by Syn3, it no longer kicks off the Update process.

I have tried several different USB sticks and done several soft and master resets with no change. I found the following link regarding the no update issue but I’m not sure I understand how to make it work:

There are a lot of warnings when changing the options (MY20 protection) and although the APIM is most likely original (it was on Sync 3 1.0.15139), I don’t want to select the wrong settings and end up bricking the unit.

Am I missing something? Appreciate any help!


SYNC Region: NA

Navigation Variant: Nav

Manufacturer Year: Pre MY20

Install Type: OEM

Old SYNC Version: 3.0.20204

New SYNC Version: 2.2.17011

Do you have a error message, if so what is it?

Update Method: CyanLabs Manual Method


Syn3updater does not support 3.0, so if you would like to go back to 3.0 you need to manually create the USB.

Why is the unit not processing the update is impossible to answer since we do not have any other information other than “it does not work”.

So, please provide the following:

  • screenshot of the usb’s root you are using for the upgrade
  • contents of the autoinstall.lst file
  • screenshot of the SyncMyRide folder’s content

Also, create and run an interrogator log against the unit, share the xml file once it’s created. Make sure to set your current build correctly in syn3updater.

Thanks for the reply.

I forgot to mention in my original post that I have created the interrogator USB and tried it just prior to my post and it did not work either. I waited about a minute for the Update notification but never got it. I’ve left it on for much longer for the updates without success. I can try again and leave it longer if that is recommended.

I’ve also tried to do the wireless update from Ford but it seems to get stuck in checking for updates.

I have verified that the correct current data is in the Syn3updater. Here’s the info requested when using the Ford files but with a drive formatted by Syn3 to update to 3.0.20204:

Root folder screenshot:
ford sync root

autoinstall.lst contents:

; SYNC3 Consumer Assembly Upgrade - Release 3.0.25 - Only for Nav/NA assemblies.

Item1 = HB5T-14G386-THB
Open1 = SyncMyRide\HB5T-14G386-THB.tar.gz
Item2 = HB5T-14G386-TCC
Open2 = SyncMyRide\HB5T-14G386-TCC.tar.gz
Item3 = JR3T-14G391-CE
Open3 = SyncMyRide\JR3T-14G391-CE.tar.gz
Item4 = JR3T-14G381-AX
Open4 = SyncMyRide\JR3T-14G381-AX.tar.gz
Item5 = JR3T-14G423-CB
Open5 = SyncMyRide\JR3T-14G423-CB.tar.gz
Item6 = GB5T-14G386-AC
Open6 = SyncMyRide\GB5T-14G386-AC.tar.gz
Options = AutoInstall,Delay

SyncMyRide folder screenshot:
ford sync smr



That’s not good, since we can’t see what’s on the unit…
What package was used?, the -AA one?.

Do you have any other USB device connected to the car?.

The link you provided for the FAQs isn’t really relevant at the moment since you can’t use Syn3updater if you want to go to 3.0.

The issue here is that for some reason the update is not starting.

When you downgraded from 3.0 to 2.x, what autoinstall.lst file did you use?.
Did you only installed APPS?.

One thing that you could try is just installing 3.0 without any other packages selected…

I don’t have the LST file for when I downgraded but I’m fairly certain I only installed APPS when I went to 2.2. I’ll try to upgrade to 3.0.20204 without any other packages. Can you confirm I only need to install the AX file? Here’s the autoinstall.lst:

; SYNC3 Consumer Assembly Upgrade - Release 3.0.25 - Only for Nav/NA assemblies.

Item1 = JR3T-14G381-AX
Open1 = SyncMyRide\JR3T-14G381-AX.tar.gz
Options = AutoInstall,Delay

Here’s the autoinstall.lst file created on the interrogator log USB that did not work:

; CyanLabs Syn3Updater Stable - Autoinstall Mode - Interrogator Log Utility

Item1 = TOOL - GB5T-14G386-AA_56065.tar.gz
Open1 = SyncMyRide\GB5T-14G386-AA_56065.tar.gz
Options = AutoInstall

Is there anything I can pull with Forscan to provide any data on the APIM?

Thanks again.

That looks good, try that.
About the 2nd .lst file for the interrogator, yep, that’s the -AA package which I was expecting.

Good thing you have Forscan. Only thing I can think of is to see which APIM model you have and perform a module reset from Forscan. Nothing more can be done from there.

Also, since the unit is operational, you may want to go into bezel diagnostics to see if you can see what ISVU files are described there. That may tell you what packages are currently installed on the unit.

I tried the interrogator log again and left it installed for several minutes without any change.

I ran the bezel diagnostics and here’s the IVSU info (looks like most of the components are at different versions; not sure if that’s the issue):

Here’s the APIM model info:

I’ll try the Forscan reset tomorrow.


Thanks for the information.
Nothing stands out, really.
The other packages are for your 3.0 installation, so that seems ok.
And of course, you are at 2.2.17011.

The only thing that may be playing a role here is that the APIM is old… I’m saying this because you mentioned that going back to 2.2 took several hours, which does not make a lot of sense for a single package.

At this point, we can’t rule a hardware issue out.
The ports work, right?. I mean, Android Auto is working, and you can play music from an USB pendrive, right?.

Both USB ports work and Android Auto works without problems. I have just tried to play some MP3’s from a USB drive and the system did not seem to recognize the USB.

I have USB debugging turned on in the phone and sometimes I see an error on the screen (car screen not phone) about it not being compatible or something along those lines but Android Auto works fine at the same time. Maybe the system has a problem reading the USB?

I don’t have anything connected (USB or Bluetooth) when I’ve tried to do the update.

If you can’t play music from the USB port, which is a basic task, chances are once you solve that you will be able to upgrade. I think the message you are seeing indicates you would need to replace the HUB for Car Play, but I was not aware it appeared on non 3.4 builds or that it could affect mp3 playback from USB.

What’s causing that?, it’s hard to say, but I’m inclined towards a hardware issue more than a software one.

One thing I would try before buying parts is to double check all the cabling is correct and the sockets are properly seated. Yes, you will need to do some unmounting to reach those…

But again, I’m guessing since yours is an odd issue.
You can also consider buying a new USB HUB, both ports are serviced by the same device, so if there’s any issue there that should fix that. Also, you would need a new HUB for carplay.

Thanks for the suggestions. I tried using Forscan to reset the APIM but there was no change,

I’ll look into replacing the USB hub although I don’t use Car Play but maybe there’s some issue with the hub. It’s odd since Android Auto and phone charging works without any problems so I don’t think the USB hub is the problem.

I was looking at potentially upgrading the APIM firmware with Forscan to see if that would fix the issue. It seems that there are a lot of risks in doing the upgrade but if I’m looking at replacing the APIM anyway, I might try that first.

On a side note, I see a lot of used APIMs on eBay for about $250 already programmed with the latest version. Is this a safe way to go if I need to replace the APIM?


I have to say it’s strange that AA works but you can’t playback music from USB.
This is just my opinion, but before spending that kind of money on a “new” APIM I would try checking the cables are correctly seated and if that does not work changing the USB HUB.

Why?, well it’s a lot cheaper than a new APIM. Besides, should you ever upgrade to 3.4 you “will have” to upgrade your HUB either way to get rid of the “HUB not supported” message that will most likely appear every time you start your car (this is the message that maybe you are currently having)… That’s only solved by changing the HUB. You can read more about that here → Media Hub, CarPlay Compatible - 2015-2020 Ford/Lincoln - SYNC 3

And if that does not work, you can always change the APIM… But somehow I do not really fell the APIM is the issue here, but of course, I’m only guessing.

Firmware should not fix anything, since firmware is needed for features like calm screen… not to perform a basic task like playing music from USB…

About the USB you are using, were they ever recognized by Sync3 before all of this?. Are they standard USB?.

If the USB has the partition layout as GPT and not MBR then SYNC will not recognize the USB, this sounds exactly like what you have

Repartition the USB using MBR instead of GPT.

If you have ever used that USB to create a Windows installation image for a modern (UEFI) computer it would have reconfigured it as GPT.

I have reformatted the USB several times and made sure the partition was set as MBR. Also used the USB drive as prepared by Syn3 for the interrogator log but replacing the files or adding MP3s with the same result. All these were formatted as exFAT which should work.

The car manual says that NTFS is also recognized so I formatted yet another USB as NTFS and it actually recognized it and was able to play music from it. I copied over the autoinstall.lst file, the SyncMyRide folder with the single APPS file, and the DONTINDX.MSA file and was finally able to update back to 3.0.20204. The update only took a few minutes.

I just created an interrogator log as created by Syn3 (exFAT) and it ran without any issues.

I’m not sure if there was some issue where formatting as NTFS helped but seems like I’m now able to do updates without problems.

Thanks for the help!

It’s awesome you were able to fix the issue. Thank you for sharing a detailed step by step, I’m sure it will help others.

Personally, I was not aware that was even a thing. I’ve used all kind of formats while playing back music from USB and it didn’t matter, Sync3 would read all of them. So I’m not sure what’s going on there.

But hey, if it works, it works…
I’ll keep that in mind should anyone else comes by with issues like yours.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.