"USB Hubs Not Supported" message after installing new USB hub in console

Hello! Was updating my 2016 mustang to Sync 3.0.20204 to get Apple CarPlay, and while the installation worked, I’m having issues with the USB hub I bought being recognized. I purchased the console hub hu5z-19a387-c, which is one of the supported models, but when I installed it, I get the message: “USB hubs are not supported. Please remove.”

Any thoughts as to what the issue might be?
Thanks!


SYNC Region: North America & Canada

Navigation Variant: Yes

Install Type: Original OEM / Stock

Old SYNC Version: 3.0.-----

New SYNC Version: 3.0.20204

Do you have a error message, if so what is it?
USB hubs are not supported. Please remove.

Update Method: Official Ford

Syn3 Updater Version:

Syn3 Updater Documentation Read:

Syn3 Updater Log File

Where did you get the USB hub? There are a lot of “fake” hubs out there, especially the USB-C ones.

Media Hub, CarPlay Compatible - 2015-2020 Ford/Lincoln - SYNC 3 - Ford / Information - CyanLabs Official Community

I purchased it from Levittown Ford, so I assume that it’s good? This was the one suggested by the classic thread: https://www.mustang6g.com/forums/threads/new-sync-3-0-build-20204-nav-android-auto-apple-carplay.41251
Link: https://www.levittownfordparts.com/sku/hu5z-19a387-a.html


Uploading: 20220517_024927070_iOS.jpg…
Looks like the interchange number is not listed in the compatible interchange list - the one I received is HU5T-14F014-AD.

Interesting… I can’t seem to find it on Ford’s part site. I think I’ll contact Levittown and see what they say. Looks like from the box it says that it’s from a newer production run, so maybe this version isn’t compatible with my car?

I cannot find this part number listed in Ford inventory. It is either new or cross references to another part number. If this did not work in your vehicle, get a replacement from them.

I got a response from the seller, and they mentioned that it’s an updated part. Their suggestion was to go to a Ford dealer and then see if they can help getting it working, but I’m not holding out hope for that to work…

I ran the update again and reset my system to see if that helped, and now, the hub is recognized and it can see my phone as a media device, but not able to use CarPlay. I requested the return process to start, and will see if I can get an older piece and try that.

I did find a similar part, 2017 Mk8 Ford Fiesta USB Port HS7T-14F014-AD. So this must be a new or different part for Mustang. It could be that it is not listed as a valid CARPLAY device in the Sync 3.0 app version. It is probably a valid CarPlay hub in Sync 3.4.

If you can get a replacement, ask specifically for the -AB part number if you can get it.

@Sheepybloke

Any update on this?

I returned the old part and got a new one from a different Ford dealer. I asked them to confirm that the part number was the -B variant, and they did, but after receiving the part yesterday, they sent me the -C variant that I was having issues with. Tried it with the new part, and still having the same issue. One positive thing is that my phone is recognized as a media device when plugged in, but still doesn’t activate CarPlay. I did try and open the 3.0.20204 and view the contents to see if I could find any specific references, but I didn’t find anything in there that references those devices. Do you know where that might be in the files? The other options I’m looking at is seeing if my Ford dealer has any updates they know about, or maybe updating my Sync up to v3.1. Any thoughts?

Are you using an original Apple iPhone cable?
Do you have CarPlay specifically turned on in the phone?

Since Sync can see the phone as a media device, the hub is probably fine.

I did use CarPlay with a rental car earlier this year, so CarPlay should be enabled. I’m using a cable that I believe is a genuine Apple cable, but I’m not quite sure, so I got a new Apple Lightning cable off Amazon that will come tomorrow.

@Sheepybloke

Did you resolve the issue?

Nope. Took a bit for them to send the cable over, but even with a genuine cable it didn’t work. At this point, I think I might have to bring it in to the dealership and see if there is an update or something for the CAN database to get the new module fully connected. It’s interesting because sync sometimes sends the “Hubs not supported” and sometimes it doesn’t. CarPlay doesn’t work in either case. I might try doing the install again, but I don’t think that will be helpful. Also, turns out my voice command doesn’t work anymore… Maybe that’s connected to it as well?

Did you try both USB ports? I only ask becuse on my Explorer one of them works just fine for Carplay and the other one only works with Thumbdrives.

I’ll try again with my front USB port. I expected it to work with the one in my console, which I replaced to have the CarPlay module, but testing the other port is worth the try.

That does not work! The port in the console is a slave to the central or front hub, which is the one that needs to be replaced for CP to work.

When I do updates and Carplay I have to use the satalite USB port in the armrest console that looks like a Cigarette lighter. They wont work in the main hub for me and they give me errors. But My Thumb drive with all my music will work on the main port.

Just thought he could try it to see if maybe it would be a solution for him like is for me.

Which hub is the pass thru, the hub in the console or the hub in the console?

The one in the front part of the console. Not the one in the armrest.