2016 f150 sync 3 version 1.0.15139 to 2.2

i just purchased a 2016 f150 5.0 with sync 3 no navigation software version 1.0 build 15139 and im trying to get carplay. i have no issue buying the module but i cant seem to update the headunit. put my vin in the ford website and it says update available to 3.0.20204. i tried the wifi update but im not given the option to “scan for updates” and when i tried the usb update it just said updating for over an hour and nothing happened. i looked online and everyone says i need to upgrade to 2.2 first but i cant find a download for it. where can i find a download or how else can i update?

SYNC Region: NA

Navigation Variant: Non Nav

Manufacturer Year: Pre MY20

Install Type: OEM

Old SYNC Version: 1.0.15139

New SYNC Version: 2.2

Do you have a error message, if so what is it?

Update Method: Official Ford

So if Fords website shows 3.0.20204 available than why don’t you download it and install that on a USB?

tried that. it doesn’t seem to be working but i’ll keep trying

What does it say after you insert the USB? Did you try both ports? Are you using a name brand quality thumb drive?

There’s a intermediate 2.2.xxxx version that enables Car Play and Android auto, we had have reports of users that went from 1.x to 3.0 via the official Ford update and Android Auto and Car Play were not active. They had to manually go back to 2.2.17xxx where both AA and CP got activated, and then go back to 3.0…

It would be best to troubleshoot this first, you should be able to install the update.
If that does not enable CP / AA, we can trouble shoot that as well by installing 2.2.17011.

For this purpose, provide the autoinstall.lst file you are using, as well a screen shot of the USB’s root and the SyncMyRide folder’s contents.

What USB brand are you using?.


It does say it’s updating. but trying it twice again, after about an hour it says “installation failed the installation has run out of space or does not work with this version” and i did try both ports. also it went from gracenote version (NA-0010) before i messed with it to the version being blank after it tried to update.

; SYNC3 Consumer Assembly Upgrade - Release 3.0.25 - Only for My16 NonNav/NonEU assemblies.

Item1 = HB5T-14G386-THB
Open1 = SyncMyRide\HB5T-14G386-THB.tar.gz
Item2 = HB5T-14G386-TBC
Open2 = SyncMyRide\HB5T-14G386-TBC.tar.gz
Item3 = GB5T-14G386-SC
Open3 = SyncMyRide\GB5T-14G386-SC.tar.gz
Item4 = JR3T-14G391-BF
Open4 = SyncMyRide\JR3T-14G391-BF.tar.gz
Options = AutoInstall
Item1 = JR3T-14G381-AX
Open1 = SyncMyRide\JR3T-14G381-AX.tar.gz
Item2 = JR3T-14G423-BB
Open2 = SyncMyRide\JR3T-14G423-BB.tar.gz
Item3 = GB5T-14G386-AC
Open3 = SyncMyRide\GB5T-14G386-AC.tar.gz
Options = Delay,Include,Transaction

it’s a sandisk cruzer glide 32gb formatted in fat32


The USB should be exFAT, although I’m not sure that’s your issue since it seems the USB is being recognized, but try with exFAT instead.

Also, what Ford is pushing your way is basically a Gracenotes, Voice and Sync3 update.
Since it’s a NO NAV unit, maybe there’s enough free space on the unit to process all those updates at once.

We could try a different approach by installing them individually.

The files you need installed are:
Voice: JR3T-14G391-BF
Apps: JR3T-14G381-AX
Gracenotes: JR3T-14G423-BB

If you go to those links, you can download the autoinstall.lst file required for installing them individually, run one at a time.

But, before moving forward, I see an .xml file on the USB’s root, that’s an interrogator output.
Please share it, redact the VIN from the title and content first (open it as text).

I would like to review it before you moving forward, but I think you already know where this is going to: installing packages individually, and installing 2.2.17011 ( HN1T-14G381-SA ) before installing 3.0…

1 Like

thank you! i accidentally deleted the interrogator but i will try to run the update again in exfat and get back to you with it if it still doesnt work.

Ok, you can do that as well. But you could recreate the .xml file with Syn3updater, it uses the same package. All I’m interested in is in seeing the apim’s free space, which may cause your issue. If it’s an 8GB APIM, there’s not a lot of room to play with…

1 Like

i got a new flash drive and ran the interrogator with syn3updater like you said. it wont let me paste the whole text of the .xml since it says it’s more than two links. here is a ss from syn3

is it supposed to say 0gb?

That’s an incomplete log. The APIM is not presenting itself, so we do not know what unit it is.
It says “non-navigation”, so based on the fact you also mentioned it’s a no-nav, I would say it’s an 8GB APIM, it’s only a guesstimation.

I see you have Gracenotes installed as well, GB5T-14G423-BH.

So, at this point I would try installing the packages individually.
If this fails, there’s something else we could try.

1 Like

thanks so much. will try and report back.

it says this is invalid:

Mmm… interesting, I can’t reproduce that:

Try a different browser, just in case.

But, the only thing important for that package is the autoinstall.lst file, the file you already have from Ford’s update. Here’s the autoinstall.lst file you need:

Item1 = VOICE - JR3T-14G391-BF_1558960697000.TAR.GZ
Open1 = SyncMyRide\JR3T-14G391-BF_1558960697000.TAR.GZ
Options = AutoInstall

The package itself, you already have it… You do need to download the Sync3 2.2 package though, since Ford didn’t send you that.

All autoinstall.lst files can be manually made as well, you just need to change the file names and make them match the package you are installing…

1 Like

thanks that worked. do i need to leave the dontindx.msa or just the autoinstall and the file in the syncmyride folder? here’s how i have it now:

nevermind i think your edit answered my question. thanks!

You can and it’s desirable, but that only tells sync3 not to index the drive… Should not affect anything, really…

1 Like

everything finished installing successfully. the gracenotes version is still blank when i go to about sync but everything seems to be working. i do not yet have the carplay module. however, i did order one part # HC3Z-19A387-F is this correct?

can i tell if cp and aa installed properly before the module arrives? i do not see any options for them in settings.

also if i ever wanted to upgrade to 3.4 with syn3, would i need to buy a new module (part # HC3Z-19A387-B-G) or will this one still work?

What did you install?.

Recreate the interrogator log and see what packages are installed.

I’m not sure about the USB module, you can take this as reference → Media Hub, CarPlay Compatible - 2015-2020 Ford/Lincoln - SYNC 3

The option will not appear until a compatible phone is connected. You should not need to replace the HUB while on 3.0. I’m still running 3.0 and both CP and AA work. Have you tried connecting it?.

Take a look at the previous link for part numbers, but most likely yes, you would need to change the HUB for 3.4. Android Auto might work, but Car Play may not.

1 Like

i installed these.

i did try connecting my iphone for carplay but it’s not working. i can still play music from my phone through the usb. the hub is in the mail. hopefully that’s all that’s left. if not i should downgrade to 2.2 then upgrade back to this version?

Well, you didn’t do this then…

Yes, install 2.2.17011 and check then.

On the bright side, your APIM is now presenting itself with a model as an 8GB one, so my guesstimation was correct.

You do not have a lot of free space, so if installing 2.2 fails, you may need to remove gracenotes.

1 Like

I would do that right off the bat…

1 Like