APIM Master Clock and Nav Issues Updating to Sync 3.4

Hi, I have a Ford Explorer 2011 Limited wich I upgraded and updated to sync 3.4 (20282) with NA Navigation 119.
The problema is that when I’m on Sync 3 3.3 (build 1905) I can use navigation and set the clock to my correct time, using get gps data on clock settings screen, but once I updated to sync 3 3.4(20282) then navigation Works ok but the clock setting gives an error of GPS data not available to set clock and even the clock if I set it up manually reverts back and can’t be set to correct time.

In the other hand I have a Ford escape 2015 Titanium with Navigation with similar problems, but on this one once upgraded to Sync 3.4 (20282) I can set the clock manually (still get the no gps data even if the navigation Works) but when you turn off the car the clock reverts to other value until you turn the car on again…

Both vehicles with the 3.3 (1905) Works completely fine and this happens only on any Build versión of 3.4

Please help!!

Thanks for all your effort and I will definitely donate

JD

ALSO on climate screen AC ON button is inverted on the escape (when off shows on when on Shows off) and on the explorer de dual ac button is inverted (when on shows off when off shows dual)
ONLY on 3.4 any build on 3.3 works ok

NOTE: I’m going to split this off to a new topic since this is not necessarily a Sync 3.4 issue itself but rather a mismatch of asbuilt values being manifested by Sync 3.4…

There are a few issues that you will just have to live with when you install Sync 3 into a 2011 Ford vehicle, any model. These were not designed for Sync 3. However, the clock settings for the Explorer and the Escape can be remedied by the correct settings in the asbuilt configurations for the APIM. The Master Clock settings for both vehicles is not correct from the symptoms you describe. This was caused by the installation of Sync 3 into older vehicles.

The Master Clock settings are in 7D0-01-01 xx** xxxx xxxx.
Extended Play (EP), Extended Play Time (EPT), Clock Master (CM), 10 Minute Clock (MC), CAN Steering Wheel Control Switches (SWC).

The attached document explains the differences in various vehicles. You will need to determine what the setting currently is and what it should be. See note below.
Ford Master Clock.pdf (298.8 KB)

The climate control issue may stem from OEM settings for the climate control and whether or not the Sync control surfaces were present in the Sync 2 OEM. If they were not present on Sync 2, they will not work on Sync 3. If they were present, then again there is a mismatch in your APIM asbuilt settings for the vehicles.

NOTE: Since you were able to upgrade the units in these vehicles, I assume that you are familiar with FORScan and it’s use in editing asbuilt module values. If you could supply an asbuilt copy of the OEM Sync 2 values and the present Sync 3 values, I could recommend settings to correct the issues.

Explorer 2011 As built

Escape 2015 As Built:

Basically Sync 3 has this same values plus some changes I did for bluetooth pairing name, new Explorer boot logo, and so on… But this thing with the clock and inverted controls on the climate screen is making me crazy,
One question I have, if this is a sync 3 as built problem why does it works ok on 3.3 and only this happens in 3.4 any build

Regarding the climate, sync 2 had it and on sync 3 everything works, the problem is that in the escape for example when the screen shows ac on the ac is off, I can touch the screen and turn it off and then the ac will be on, same happens on the explorer with the dual ac buton, when I touch dual on the screen to turn it off, then it turns on the dual on the panel, then if I turn it off on the panel it turns on on the screen, and again this only happens on Sync 3.4 because on sync 3.3 or 3.0 works great

Ford fixed a lot of stuff across the vehicle lines in Sync 3.4.xxx, including the master clock and climate controls. Unfortunately this causes issues with pre-18.5 model year vehicles originally equipped with Sync 2 and 3.0.

As far as the 2011 Explorer, The value at 7D0-01-01 xx** xxxx xxxx is 21, probably should be 29 since you put a Sync 3 unit into this vehicle.
As far as the 2015 Escape, the asbuilt shows Sony Stereo DSP but no steering wheel controls for volume, etc. This does not look correct, as usually the Sony systems included these controls. This might be a 29 also if these controls are present.

The rest of the asbuilts are for Sync 2, and some of the values do not translate to Sync 3 directly.

This issue is documented on Escape, Focus, Fiesta, and maybe I’m missing one or two. If your settings for Sync 3 are the same as above for Sync 2, this could be one of the issues.

Could you post your Sync 3 values?

Hi @Jorge_Duarte,
I also had the issue with the AC & Dual buttons seemingly functioning backwards, but there didn’t end up being a software solution but rather a hardware/wiring issue due to the older model.

I have yet to find a solution to that. You’re in great hands with @F150chief, he helped sort out all other issues with clock, steering wheel controls etc.

I upgraded my 2014 Ford Limited to 3.4 and am very pleased.

1 other thing that I noticed, the max defrost setting in climate control is not functional for me. if you sort that APIM setting please let me know.

cheers,

1 Like

As mentioned, unfortunately the reversed ac controls and ac buttons not operating correctly are issues with older vehicles that won’t be fixed.

1 Like

@Jorge_Duarte
Link to the thread:
Sync 3.4 Upgrade Successful But with Minor Setbacks - Ford / Configuration (AsBuilt) - CyanLabs Official Community

Sync 3 is programmed like this:

Tried 29 and it didn’t worked, I change the bit for nonnav instead and it works great, it gets gps signal for the clock and everything is perfect, if I activate navigation, navigation works but the clock gives the error not gps signal and can’t be fixed

Could you clarify which vehicle, I’m thinking the Explorer?

When you replaced the Sync 2 to Sync 3 in the vehicles did you add the GPS antenna for the Sync 3 unit and leave the Sync 2 antenna in place or remove it?

explorer!! of course I added fakra antenna and leaved sync 2 antenna in place, also tried unplugging the gpsm module, nothing seems to work, but if I downgrade to 3.3 everything works or if I stay on 3.4 but change the apim from nav to non nav everything works great