Issue updating Sync 3 Software

Tried an update from 3.0 to 3.4.20351 today (system, maps, all the bells and whistles).

Used a 32GB stick started the update; it all went fine for about 40 minutes and it crashed with some random orange screen and rebooted. It seemed to start again with formatting eMMC and it failed, reboot and now it is stuck at “Please Insert USB”.

I tried to stop the car, lock it, open doors, etc. however to no avail. Created a 2nd stick (different one) and tried it, still the same, I am stuck at “Please Insert USB”. Looks like the USBs are not working anymore.

I will try again in the morning, maybe removing the fuse for the head unit.

Any advice to recover, or I am in for a full head unit replacement since this one is toast?



Tried again this morning (a few hours later) with a stick without maps, the update went through from 3.0 to 3.4.

I only have a “Map malfunction” (obviously). I am wondering if I can only install the maps now, without any reformat, re-flash that would make me risk bricking it or the insert USB again …

If you didn’t choose to install maps when doing the reformat then you cant install them standalone. You must reformat again. This will now involve a downgrade to 3.3 and then a subsequent reformat back to 3.4 with maps.

The Syn3Updater app should handle this all for you if your current configuration is up to date.


Yeah, researched more and figured that much. Will do the procedure through the app and downgrade/reflash. I will also remove any nav voice to make the package smaller since I don’t see myself using the nav too much, I just hate the “error” it shows now.

Also, I am worried about the USB failing on me again, the reason why I am installing only the app and maps, no voice files.

Moved to own thread to not clutter the discussion thread for new features/bugs

1 Like

Guess my USB electrical connection is bonkers, heats up, gives up after a longer period, don’t know. Might be the reason why it didn’t recognize the USB after the long install and it failed the first time I tried.

Created a new “package” with the downgrade / reflash procedure in the app after I have installed the 3.4 only (without maps).

Went through the procedure, after 40 mins all is ok, 3.4 is working with the NAV and Maps.
I haven’t flashed any voice files (since they are rather big and I reckon it would take an additional 20-30 mins to extract those).

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.