Issues after update

Good afternoon. I have a Ford Kuga and updated the 2.3 Sync 3 to Sync 3.0 20204 - it did it some via wifi and then with a USB stick. Once it installed, after a few days the navigation stopped working - it is exceptionally lagging and takes a few minutes or seconds to change the screen to anything else - I have looked on the forums and see this is not uncommon, but my question is, if i use the updater and install either 3.3 or 3.4, what is likely to happen? Ford are being their usual selves and say £160 to diagnose, even though I am sure it is the software, as the rest works, just painfully slowly…

Thanks in advance for any advice or help…

SYNC Region: EU

Navigation Variant: Nav

Manufacturer Year: Pre MY20

Install Type: OEM

Old SYNC Version: 2.3

New SYNC Version: 3.020404

Do you have a error message, if so what is it?
No error message, just very slow

Update Method: Official Ford

Have you tried performing a master reset?
Its not unusual to need one after an update.

1 Like

Evening, I have tried a master reset, although I suspect that this is not happening properly, as the presets on the radio are not deleting - it is saying that it is…

Only Sirius XM presets would clear on pre-2020MY APIM
Regular AM/FM are stored in the ACM, not the APIM.

Easy way to check if you’ve done a master reset would be if your sound settings are back at defaults and if you have it NAV settings would be back to defaults with all your history and favourites cleared.

Oh great, so that means it is master resetting, just not fixing the problem - what do you think next? I can try to reinstall 3.0 02404? or force an upgrade to a newer version?

I would follow the steps to go to bezel diagnostics so that you can get a list of what packages are installed.
It’s possible that one or more didn’t get copied and from the list we can see if something is missing or the wrong version.

Why don’t you go step by step…
Perform a master reset as recommended, then we will discuss options…

But let me tell you 3.0 should not run slow, nor have dysfunctional NAV out of the blue…
So if you are having those issues on 3.0 chances are upgrading to 3.4 won’t fix it, maybe it will hide them for a while, but that’s about it…

Thanks - I have done the master reset and it is still the same - I will look at the diagnostic screen and upload the photos of what it is saying… hopefully there is an easy solution!

Just to manage your expectations, consider the unit unhealthy from this point on.

So I opened the diagnostic menu, this, I believe is what you need to see?

I have only installed 3.0.20204 from the ford website and it previously said it was on 2.3 not sure the build number…so not sure where those other numbers have come from or if that’s normal…there is one other number below but I can only post one image…that number is the same part number as the bottom one except it has a 22 rather than a 21

Thanks for your help, I really appreciate it

These are the other photos

I’m not sure why you are @'ing me, I was not the one who asked for that information.
Also, avoid posting multiple consecutive messages in the future, if you want to add information use the edit button instead.

The app file shows as installed.
If you go to does 3.0.23219 show as available?

Apologies, went from an email and am new to the user interface…

No it doesn’t - it says up to date - what is the 3.2 all about?

This is still a 3.0.x family build, not a 3.2.x

3.0.23219 dropped on 4/27/2024 and so far the notes just show “continuous software improvement”.

If it makes a difference the system seems to work better when there is a working USB in the port…

So, at this point, as I said before, consider your APIM unhealthy. I’m also running the “original” 3.0.20204 Ford pushed my way and it works ok, so it’s not a 3.0 issue…
That means your APIM could be dying…

One thing you must do before moving forward (should you choose to upgrade to 3.4) is running an interrogator log… that will tell us a bit more about the unit, specially which type of APIM is…

If you do run it, share the XML file with us… you can redact the VIN from the file’s title and content if you care about it.

Version JR3T-14G381-AX
APIM Model: JL7T-14G371-FCC
APIM Type: Navigation
APIM Size: 64GB
APIM Free Space: 20G
30/04/2024 20:19:49 +00:00

Partition Type = Free / Total
/fs/usb0/ = 15G / 15G
/fs/tmpfs/ = 127M / 128M
/fs/sd/MAP/ = 4.5M / 1.5G
/fs/sd/MAP/ = 79M / 14G
/fs/Nuance/ = 843M / 15G
/fs/Nuance/ = 7.6M / 1.9G
/fs/Nuance/grace = 6.1M / 1.0G
/fs/rwdata/ = 696M / 1024M
/fs/mp/ = 40M / 1024M
/fs/images/ = 20G / 55G

Installed Packages

APIM AsBuilt
DE00: 0B6845DA9002BE170002
DE01: 554B01044003480000000005
DE02: 0400010000
DE03: 01001C01250007
DE04: 18061810295F
DE05: 80
DE06: 1704330000000000FA00000430750057

Thank you for the file.

There’s one last thing to try with your current setup.
Some have said that the system could get slower due to the new Sync3 version you installed and old/corrupted map installation.

So, take a look at this guide: Tutorial: Sync 3.0.20204 with 2022 EU 2.21 (F11) Map Installation

I’m not sure if that’s your case exactly, since you mentioned NAV stopped working… but it’s worth a shot since your maps are really old as well.