Issues with rear view camera after upgrade from 3.0.20204 to 3.4.21265

Hello everyone,
Upgraded few days ago from stock 3.0.20204 to 3.4.21265 on my 2017 S-max. Only main drawback I’ve noticed is the dimmed/dark rear view camera picture when reversing. Very disturbing as it is almost impossible to reverse relying to RVC. Yesterday I’ve found workaround - swithcing off headlights when reversing brings back normal brightness to rear view screen. But this is not the situation I’d like to live with. I have no proper OBD adapter so far for using with Forscan. I’ve performed interrogator log procedure and tried to upload .xml result, but the online xml parser seems to be buggy as it gives the error.
Your suggestions would be appreciated, how to deal with this issue?
Tnx

Hello.

I’ve separated your thread since it does not really fit the build feedback thread, since you are having now issues with the interrogator.

Can the interrogator log that’s created be opened by Syn3updater?.
It may be corrupt, maybe. If it can be opened, you can get some information from there.

Also, have you master reset?.

log file is readable by Syn3 updater, but if I try to upload it directly from Syn3 or upload it manually via web browser, I get the error.
Yes, I’ve performed master reset as instructed in update tutorial, actually did it twice already - right after update process and yesterday once again.

Okey!

Can you upload the xml file here?.
Make sure to redact the VIN from the file’s name and content if you care about those things.

In the meantime, you can check this thread: 3.4 dim reverse camera screen

It’s not for your specific model, but if you do not have access to forscan it’s worth trying.

Thanks.

sure, here is the xml
Sync_LV9P00Z5.xml (14.4 KB)
I’ve read this suggested topic, this dimming is not controllable neither from vehicle dash illuminating knob or by APIM-s brightness, daytime settings.
It seems to be related to illumination scheme which is tied to headlights automatics - if headlights is on (dusk, dark) the RVC is dimmed, when no headlights on, only DLR-s illuminated, then RVC brightness is back.

Not sure if I’m following you, or if you are following me.
The thread I mentioned clearly states that someone with similar issues like yours solved their issues by downgrading the Sync3 version, no other modification was needed. I’m not saying it’s your solution too, but it’s worth trying, just to rule things out.

About the XML file, there’s something wrong with it.

image

This does not make sense, and I can bet this is why the online decoder is failing.

What package did you use to produce this file?.

yes, this is the only action I haven’t done yet - downgrade.
About package - do you mean Syn3 updater version or exact tar.gz file?

No, I mean the interrogator log that produced the XML file you uploaded.
You created an Interrogator Log USB, that USB has a package contained.
Which was it?, GB5T-14G386-AD?, -AC?.
Was it ran against Sync3 3.4.2165?

yes, against latest version 21265

image

Ok, it should work, but it’s not.
Try with GB5T-14G386-AC . Copy the file there, and modify the autoinstall.lst file on the root to point to the new file.

same result, only rows of FFFFFFF… :thinking:
maybe I’m doing it incorrectly, should I remove USB when dialog on screen says it to do or i have to wait 'til APIM reboots and then pull the USB off?
However, I have xml produced by previous stock version 3.0.20204 , may it be useful?

What’s the background of the unit?, has been it serviced in the past or something like that?. You mention it being stock, but there’s something odd with it.

I tell you what I would do: I would downgrade to 3.4.19101 and see what happens…

The interrogator usb does not reboot the APIM, so you only have to wait a few moments after seeing the “update in progress” message. Check the interrogator log tutorial for further details.

About the older 3.0 xml sure, send it.

here’s previous log
Sync_LV9P00Z5_3.0.20204.xml (10.1 KB)

This is the last time I ask:

The 3.0 log shows this:

The 3.4 log shows this:

So again, what’s the story here?. Is there anything you are not telling us?.
3.0 log is properly formed and declares an APIM while the 3.4 log does not…

At this point, if it’s the same APIM, there’s something wrong with the current installation since there are some information missing.

If it’s the same APIM, I would try again using another build.

never had issues with the infotainment system/APIM, updated only with the official updates provided via ford.co.uk, one time updated by the Ford dealer’s service. I’m not trolling, believe me.

That’s ok, and sorry if it came out strong, I was just saying I won’t be asking questions 3 times.

At the moment I believe your 3.0 log is ok, but there’s something wrong with your 3.4 system. Either the APIM is acting up, or the installation has something strange on it. Not being able to generate a simple XML file with basic information about the system is not expected.

What I would do is downgrading to the 3.4 build mentioned in the other thread, to see if that makes any difference.

Also, from the 3.0 log you can see all the ASBUILT parameters you want, since that log is properly formed, you can upload it and view your configuration in detail.

1 Like

Yeah, this is good I’ve kept the old logs. I will play with the log tool awhile, if I’m not able to get AsBuilt info from APIM after reasonable effort, I’ll go with the downgrade strategy.
Syn3 states that suggested 19101 version has something to deal with auto-brightness.

That has nothing to do with RVC brightness, but to the auto brightness toggle in the configuration. After that build, auto brightness is always enabled and you can’t change that, there’s no toggle/setting anymore in the UI.

The Interrogator log file is not designed to be uploaded to the SYNC 3 AsBuilt Decoder, there is no issue here in regards to that. This decoder is used for UCDS XML files, ForScan ABT and Ford AB files.

EDIT
HOWEVER: if it was uploaded via Syn3 Updater then there is indeed something wrong, can you confirm if the file was uploaded via the webpage or via Syn3 Updater?

So like i believe @SaNdMaN said, the file is corrupt, to make this clearer in the future i have tweaked the site to show a friendly error message