Navigation is still loading

What is your SYNC Region? EU

What is your current SYNC Version? 21020

Do you have Navigation? Yes

Hello everybody. I have just updated to 21020 from the Ford website directly. It took almost 3 hours (!) but everything seems to have worked. I got an XML file at the end too.

There is a weird issue though. I have saved my home address as a favorite. When i hit the voice button and say “Navigate Home”, it responds verbally with “The navigation system is still loading - please try again later”. It’s the first time I’ve had this and not sure what or if something is wrong. I tried a master reset but it does the same. Could it just need to sit for a while?

Many thanks

Just let it finish the map parsing in the background.

All right. I hope that’s all it is. I will give it some extra time and I’ll check again. Had never noticed this before.

Not sure how long this is supposed to take but there’s still no change…

Even if i say “Find an address” I get the same message that the system is still loading… Could there be something wrong with the voice files?

Something is not right with the installation. This is a known issue with the Ford packaged map updates. You could either run the complete update again or use the Syn3 Updater to do it.

Oh wow… I really don’t feel like doing the whole update again. It took 3 hours to complete!

If i use sync updater to just do the voice files, will it work you think? Can I use the voice files of the latest version or will i have to specify 21020 voice files?

If I do just update voicefiles with the newest available, will that conflict with future ford updates?

Many thanks for your efforts, interest and help.

For EU full installation of the Sync app, System voice, GN, EU maps and NAV voice will take about an hour. If you stay with the present Sync app version you have now, the Ford update system will never know the difference, and it is totally compatible, as it is the exact same files, just a different installation method.

I recommend that you install the complete package thru the Syn3 Updater. It will downgrade your unit to 3.3.19052 first and remove GN, this is normal for the app to run properly with adequate free space to do the updates. Ford does not do this and it results in these issues.

The process will reformat the storage, wiping out all the previous installations, but it will keep your programming, and start with a fresh disk installation. This also removes misc log files, etc., that may have been orphaned from the Ford installation processes. It will take about an hour to complete, as the EU maps are large.

Here is the documentation to the Syn3 Updater. Read this before you do anything…

Syn3 Updater | Cyanlabs Docs

All right thanks for that.

Please verify if i understand this correct. Are the following points correct?

  • Since my current version is 21020, if I setup sync updater to install everything on the same 21020 version, including maps, it will do a format and fresh install of everything and I will end up on 21020 again.
  • Since i have already posted my XMLs on the ford servers, as far as they are concerned im on 21020.
  • In the future when they release the newer version, will I be able to get it (either from them or via updater) and be able to generate an XML to let them know I’ve updated?


Yes, but it’s just an all automated system. No one checks…


Sounds good. I will set the updater up to download everything overnight since I have shocking internet…

I really hope this time it will not take 3 hours again as it was painful to install via the official method… Plus it took like 1/4 tank of fuel driving around haha.

Thank you for the info. I’ll be back with the results…

See your DM…

Hmm have you sent me a DM somewhere? I’m looking and I can’t see anything haha. Where can I find it?

EDIT: Nevermind, got it :slight_smile: Thanks

I prepared the usb after F150chief’s help and decided to go with the latest version of sync.

All went well and much much faster than the official method.

The process completed, I performed a master reset but unfortunately, the nav voice situation is the same. Every time I say “Find an address” or “Take me home” or anything of that sort it comes back with “Navigation is still loading - please try again later”.

Should I panic or could it really need more time to process things? I drove for like 40 minutes after the upgrade.

This is the same issue as I was facing via the official method.

The navigation and maps work fine and if i type an address in it’s all working perfectly.

Any clues?

1 Like

Are you the first owner of the car?
Also, I would wait a couple of days to see if it gets solved by itself…

It’s a really strange case…

Yes I’m the first owner. My car does not have a modem. It’s a febraury 2019 built ford focus Mk4

Ok, I would let some days pass to see if there’s something else at play.

Just to be clear, you used reformat, right?

Yes sir. Reformat, downgraded first then installed latest + f10 maps.

I forgot the usb stick in the car but ill grab it tomorrow. Will I be able to find any post-install logs on there that might be of any use to you for possibly diagnosing whats going on?

No, there’s no log from the installation itself.
But should not leave the USB in the car, I think it may trigger a new update.

What you could do, is to create an interrogator USB: that will read what’s in the APIM, which partitions there are… People that have more knowledge than me can read that so see if everything is there…

I asked if reformat was the method because that installs EVERYTHING from scratch…

Haha don’t worry I didnt mean i left it plugged in. I just forgot it in a tray somewhere :stuck_out_tongue:

It was reformat indeed. I’m starting to think the new voice files might have an issue with my region somehow.

Complete reformat with everything…I sent you the invite.

1 Like