Version 22251 Issues Arising?

Thanks for replying.
I’m still at 3.4.22251
I tried last night to downgrade it but no luck, i got Err80. And based on what NaNdMan said rwdata is full and I am trying now to solve this obstacle.

This double reset works…but for the short time…I have to proceed this action every 3-6 days…It sucks…

That’s not a solution. That’s only to make enough room to perform other actions to correct the issue by reformatting the unit if not MY20, and of course installing another build.

1 Like

Just ordered the Forscan unit to perform the formatting and see what happens. Will post the update soon.

What do you mean by “format”?.
Reformat is not done with Forscan.

I meant a jailbreakto clear the /fs/rwdata partition

Following situation:

Version of Sync: 3.4 Build 22251

Information from Interrogator utility:

<d2p1:PartitionHealth type=“/fs/rwdata/” total=“1.2G” available=“0”/>

Update/Downgrade Soft reset etc. Nothing works.

Now, I did a Jailbreak with Forescan.

After the 3 steps it looks perfect: no errors.

In the last step I saw the A-TEAM “Mods Tools have been installed” notification pop up. Simply remove the USB and let Sync 3 reboot.

Now I want to read in the script file with the name:



function displayMessage {
echo “${1}” >> /fs/usb0/SyncMyMod/install.log
echo “${1}” >> $POPUP
/fs/rwdata/dev/utserviceutility popup $POPUP
#echo “${1}”

displayMessage “Deleting /fs/fordlogs”
rm -r /fs/rwdata/fordlogs/*

displayMessage “Deleting /fs/slogs”
rm -r /fs/rwdata/slogs/*

displayMessage “Deleting /fs/dumps”
rm -r /fs/rwdata/dumps/*

displayMessage “Script complete.”

But the Sync3 didn´t recognize the USB drive.

I am sure this is my mistake, because I don´t know how must look the folder structure of the USB drive.

What I need? SyncMymode? DONTINDX.MSA? I must change something in the script, that it works?

Thank you in advance.

I have found the rwdata Cleaner now.
But. The cleaner make the message no mods tools.
The installation of the mods tool is working: No error.
But it seems, after rebooting of the Sync the files are not saved in /fs/rwdata/dev. :money_mouth_face:

Any ideas?

1st, do not doble post. There’s an edit button for a reason
2nd, you should ask in FMODs.

I’m at the exact same point you are. Please let me know if you reach a solution

I’m in the same boat… rwdata out of free memory. Doing the MR + SR + SR yielded 3.5M/1.2G free. However still not enough apparently to downgrade to 22200–get the VER_ERR80 still. More reports trickling into the Explorer boards of people losing settings so I suspect this will turn into a major problem–especially if Ford doesn’t come out with an easy way to clear the memory to make it possible for a version update.

Why are you doing that exactly?. Is your unit MY20?.
If not MY20, have you tried doing what the troubleshooting guide says?

Yes, MY2020.

same here. Hope someone post a solution!

I see. Then you need to jailbreak the unit to recover it …

This may be a long shot based on my own firsthand ‘non-issue’ experience with this build and educated guesses from various scattered posts: But if you can manage to get it to cooperate, try connecting it to Wifi and turn on all the ‘diagnostic’ settings sending data back to Ford. That’s SUPPOSED to wipe the log files as well from what I’ve gathered. Though if the MR+SR+SR process hasn’t helped, this may not either. But can’t hurt IMHO. Other than that, @SaNdMaN’s right and a JB would be needed.

Was 22251 ever offered by Ford officially or is it one of the many dev builds in between?

So I made another attempt to free memory and this time downgrade to 21265, using MR + SR +SR + USB stick. To my surprise, it got to the end. On reboot however, there is a splash screen but a blank screen afterwards. I have tried soft resetting and key cycles. It’s the same. Splash screen then blank. Interestingly, if I shift into reverse, the rear camera picture shows. The APIM appears to be working but has no screen, no audio. Should I try loading a different build to see if that works? At least the rwdata has free space now!

Update: This morning, I loaded up a USB stick with 22200. I intentionally used a USB stick with activity LED so I knew when it finished. Still, on reboot, it was a blank screen after the splash screen. However, I left the car running to go back in the house, and the screen and menus are back!!! Maybe 21265 was good but I didn’t give it enough time? Or maybe the install was corrupted in some way? I made several 5 minute trips yesterday and it was a blank screen throughout.

MY2020 Ford Explorer. Did not use reformat and left protections in place. This was immediately after installing 21265 (despite the blank screen).
/fs/rwdata/ = 567M / 1.2G

That’s good to know!. So… after all that, the unit now has about 500MB of free space for that partition, which is awesome. Was it connected to WiFi?

Monitor how the partition is in about a week… if it’s hovering that number, you should be safe…
But it’s quite interesting that a “simple” downgrade freed up about 700MB… But I feel this has something to do with internal Sync3 processing, hence the question if it’s been connected to WiFi (based on what’s been said by Vchat20)

Yes, immediately after 21265, it was 567M. Not sure why my previous attempt to install 22200 failed with err80 even doing the MR/SR/SR, but I was able to install 22200 after 21265.

I do not have my car connected to wifi at all and autoupdate turned off but still ran out of space with 22251.

Will definitely keep an eye on rwdata.

1 Like

Thank you, keep us updated please.
Your case is quite good to follow, since it would be another alternative for users to mitigate the issue without JBing the unit. It’s not a definitive solution, but’s a good and valid workaround to try.

@jimp @Hesse @ajakewampler , please try what C_Wu said before.