Black screen after update

Help! I have a 2016 MKX, which had 3.0.19205 which I tried to update to the 3.3 version. The update said successful (very quickly) then said it would be finished when I restarted my car. Screen went black and will not turn on. I’ve tried the soft reset of the audio power and seek up. Nothing. Also pulled fuses and the main power. Can anyone help? Did I brick it??

Hmmm… we have had some 2020 vehicles get a black screen, but not a 2016. Did you get your apim (sync module) replaced with a 2020 model module.

1 Like

Shit. The dealer said they “replaced a module” during a visit three months ago because in reverse, my screen would go black or freeze.

Sorry man. Its probably that they replaced it with a 2020 module and the reformat bricked it. I really feel bad for you, since you replaced it recently for the exact same reason. Shouldn’t that module already come with 3.4? Let’s make sure if its really the reason why if we ask @F150chief. He’ll know more.

1 Like

You probably have the receipt for the service at the dealer. Look at it and see if there is reference to the item replaced. They probably did not replace the screen with a 2020 version because 3.0.19205 would not support the drivers needed to make it work. I have a theory that you had a theme selected that is discontinued in Sync 3.4 and that is the reason the screen is black. Unfortunately, it will require FORScan or Ford IDS to fix it.

I have something you can try to find out if this is the case. Run the APIM Interrogator Utility. You won’t be able to see anything, but I would bet the APIM is running. Leave the usb inserted for at least 3 minutes, then remove it and look on the usb for the xml file mentioned in the tutorial. If the APIM is running, the xml will be on the usb, if it is not, it doesn’t mean it’s totally dead, but you will need to access the unit with FORScan or other tool.

Tutorial: Tutorial: APIM Interrogator Utility - Ford / Guides & Info - CyanLabs Official Community

Do you still have audio and can adjust the volume? And tune stations?

2 Likes

No audio, HVAC still works with buttons. The only thing that it will do is that the light around the USB port (not the one in center console, but the one under the center stack) will fade/flash once every six seconds or so ONLY when I press audio on and seek up and the same time. Other than that, nothing. I figure this is good as it still responds to something?

Did you try this, if not give this a try

1 Like

Thanks so much for your help. I did this, no luck and formated the USB drive and did it again for the hell of it and no XML file. I ordered the FORscan OBD adapter tool and it will be here later today (thanks Amazon)
Any advice from this point?

Read this tutorial:

FORScan Tutorial - Google Docs

Load FORScan 2.3.38 (or latest). Connect to the vehicle and save the asbuilt for the APIM if you can connect to it. Then go to the tools icon and find the reset for the APIM. Perform a reset, it should reboot, but see if it comes back.

Post the abt file for the APIM here, or just copy the contents.

2 Likes

APIM - Accessory Protocol Interface Module
Part number: JR3T-14G371-BJD (latest known: JR3T-14G371-BJG)
Strategy : HB5T-14G374-CA
Calibration: HB5T-14G375-BA

1 Like

The firmware is correct for that model. Connect to the vehicle and the APIM with FORScan and save the asbuilt file. (If you can…)

I have a 2020 APIM with screen and also 2018 APIM with screen the 2020 has F8 maps is it just a case of swapping screen over then reformat the 2020 APIM then swap the screens back afterwards and everything should be ok?

1 Like

Don’t do it!

The problem is the screen drivers, which like in your computer, live in the CPU system, not the screen. I may be wrong but I would not do this…

Ok I’ll not touch it,is the problem with all the latest APIMs i.e with only one USB port(my 2018 has one port but with the hole where the other was)? Or is there a certain cut off date?

1 Like

Gen 2 Sync 3 APIM’s and up have 1 usb connection on the rear.

The top one is out of a 2020 mondeo the bottom one a 2019 mondeo I’ve swapped the screens over and both work ok?

1 Like

The JS7T is a 2018.

I know that some models have not gotten the newer screens, but it’s been a mystery which models do and don’t. I don’t know if this means that the reformat will work properly or not on the LS7T unit. I wish we had better data on this.

Some folks have had success with this, but as a precaution I always error on the safe side with other peoples equipment. It’s up to you if you want to try this, but that’s your responsibility.

I read the earlier topic from this year about someone that had a 2020 APIM from a fiesta and used his screen from the 2018 APIM and he got the screen of death but with a full reinstall got it all up and running,maybe I’ll hold off for a while until there’s more info thanks for the info :+1:

1 Like

Just a quick one do the very latest APIM says 3.2 on the front like mine or do they say 3.4 now?

I haven’t seen that on US APIM’s but maybe on the European ones.