SiriusXM Logos on 3.4?

Hi,

I have a 2017 Lincoln MKX in the US/Texas region. Last year I updated to 3.4 (w/ Nav) using the tools here. Everything went smoothly, except for losing SiriusXM Channel Logos. Its not a huge issue or anything, but still a minor annoyance for the times I am listening to Sirius. Today, I updated to the latest 3.4.22110 hoping that would help, but still the same issue with no logos.

Every few months, I keep searching around the web and forums just looking for any possible workarounds. It seemed that the general consensus is that its just kinda random on if it’ll work or not. I’ve tried every refresh and reset trick known to no avail. However, I stumbled across a recent thread that gave me a small glimmer of hope: Xm radio logos disappeared

Reading through that thread, it sounds like there might be a AsBuilt config change that could potentially resolve it. I was just going to reply back in that thread, but its already closed/locked.

Would anyone be able to take a quick glance at my AsBuilt for my APIM and ACM to see if there is maybe something there that might resolve this? All of these should be the same default values as when it was new, as I don’t believe I’ve made any changes here. But maybe there’s something 3.4 specific in the ACM that needs a quick update? If it matters, its a 2017 Lincoln MKX Black Label with the Revel Ultima sound system, bought and used in Texas its whole life. :crossed_fingers: Thanks in advance!


APIM

ACM

2017 MKX.
What is the firmware version of the APIM?
What is the firmware version of the ACM?
Your asbuilts are proper, no issues.

How can I get that? I searched around in forscan but couldn’t immediately find them listed anywhere.

I found this from the APIM diagnostics if this helps:

Same here on my mom’s 2018 MKX Reserve, and I agree not that big of a problem but makes it look basic lol, did the same process with my 2015 Taurus SHO with a retrofitted SYNC 3 unit and retained logos on that one. Was looking forward to reformatting this evening with the new maps and 22110 to see if it fixes but oh well :frowning:

That works.
The unit is an HB5T-14G380-BA, 2017 vintage.
3.4.2210 is loaded.
The firmware is:
Strategy - GB5T-14G374-CB
Calibration - GB5T-14G375-CA

I don’t see an obvious reason that the Sirius channel logos would not show, unless there is a conflict with the 2017 firmware and the 2021 software, which is always a possibility, but I have not seen this to be an issue.

By the way… the Sirius channel logos are built into the Sync software. Only the ‘special’ or seasonal channels are downloaded over the air. The channel logos are located in the Sync app under the sirius_chart_static folder in the image.

Have you re-saved the presets?
The Sirius radio presets are in the ACM at 727-08-xx, in the pic above. With FORScan you can see them change as you save them. You have to refresh the page. This will tell you if the presets are working right and the radio and APIM are talking properly.

You probably sent a Sirius refresh signal to the ACM already?

sorry to chime in so late, being that im in the same boat, and possibly @F150Chief could clarify it for me, the gentleman who created this post, i understand he has a lincoln and me a ford but i noticed in his acm module as built his starts with 10A0-xxxx-xxxx, mine is 0A00, i understand his came with far more bells and whistles being mine was a retrofitted interceptor, could that potentially be my issue considering ive tried all else? the 0xxx-xxxx-xxxx in mine registers as sdars enabled, gen 2 apim, efp can based but no apim, which i know i have an apim lol.

lastly could changing my acm to one built in 2018/19 help this at all? they can be had on ebay from a junked car. i think my acm also starts with gb5t. the newer ones start with jb5t.

i was sifting thru @F150Chief databases for stuff and learning the breakdowns of all the numbers and letter in each string. i also tried refreshing the signal for the xm radio.

You should likely have 18A0-xxxx-xxxx. If this disables your SWC, then change to 1AA0.
10A0-xxxx-xxxx is standard setting for Sync 3 with SDARS and HD Radio.
18A0-xxxx-xxxx is standard setting for Sync 3 with SDARS without HD Radio.
You could change the ACM to the JB5T directly.

1 Like

its chinese at first but i understood it after reading it carefully, i do have SWC, given that my interceptor had sync from factory, prior to the retro fit i had aux, usb, bluetooth and voice command. ill switch it to 1Aa0

ill scout a good one out and purchase it.

I edited the settings above, I was misreading something…

i literally saw it change lol weird!

my speakers are run by the acm originally but the rear speakers were always lower even after changing them. i guess thats the set up for the interceptor lol the prisoners didnt need tunes. but ive amplified my rears with a external amp so all good there.

im gunna try 1A00 seems like it matches what i have perfectly.

Right, if you don’t have the Sony system then that would be correct. Thanks.

Of course sirius website is down for maintenance so i cant send a refresh signal lol. Anywho i got the coding changed so ill try refreshing it on my way to work in the morning.

Yeah I tried the refresh signal, still no dice. I thought maybe part of my issue is how my car (both at home and in office) is parked in a garage with no signal. But I just had my garage floors re-done so its been outside for a few days now. I was kinda hoping having that more consistent signal would have done something, but no change thus far.

I pretty much haven’t changed the presets since I got the car (when it was on 3.0), but I went ahead and made a few changes, and they seem to be sticking just fine. Checked forscan, and the values in 727-08 did change.

I think I read somewhere else (I think on the f150 forums) that 2017 ACMs were “Sirius” only, while 2018+ were “SiriusXM” branded, and that could be a potential conflict. But, in my wife’s 2016 MKZ, I retrofitted a 2019 Sync 3 (w/ Nav) APIM and her logos show no problem. Granted, that APIM can “officially” get 3.4, but it seems to hint that it might not be ACM related. I guess thats the confusing part.

This is absolutely not the case. When XM bought Sirius, they gave everyone plenty of time, like a year, to transition to the new lineup. XM kept the old Sirius distribution platform for a long time after that, before merging the 2 platforms to the same distribution system. Basically, they ended up with 2 distinct SDARS systems, which became expensive to maintain as it takes (theoretically) twice as many satellite transponders. Recently, SiriusXM pulled the plug on the older Sirius platform and transitioned everything to the XM platform. (Which is potentially better as far as bandwidth and quality capabilities.) Ford, and others, finally started using the newer XM chips in the radios about late 2019. GM and others who were originally XM based also had to make the new radio conversion. The new radio platform for SiriusXM is finally fully capable of delivering quality content with very good listening experience. It’s a shame they choose not to do so. Sirius is no now more but part of the name.

Thanks for the detail and for your help. As another side note on your earlier comment about downloading seasonal stations over the air, i’ve actually never seen those either. Seems like it wont show the built in logos, nor the over-the-air downloaded ones. Not sure if that means anything.

Let me know if you come across any other tweaks i can try.

@RD4154 has had some luck with his setup, but his is an upgrade from the 4" screen on a police interceptor Explorer. Maybe he can chime in…?

The only thing that I can suggest for this is to update the firmware on the APIM with FORScan. I do not know if that is the solution but it’s the only thing that has not been changed. I am wondering though if the 2017 MKX’s don’t have the required wiring to support this using Sync 3.4. This is just speculation…

would a generational apim cause an issue if im not mistaken the one i recieved in my kit was a 2018 year range apim mine starts with JR3T and after todays harness change i got my logos. mine has the solo usb connection on the back and a blank space next to it

RD4154, you mentioned (and after todays harness change i got my logos.) what do you mean.